Negated boolean names
ID | NAMING-3 |
Title | Negated boolean variable names shall be avoided. |
Priority | Strongly recommended |
Severity level | 8 |
Description | Avoid variable names including the word not. |
Rationale | Readability decreases when variables have negated boolean names, especially in combination with the ~ operator. |
Avoid:
if ~notValid && isNotFound
error('My error message.')
end
Instead use:
if isValid && ~isFound
error('My error message.')
end